Gross Orders and Revenue Under Reporting

Incident Report for 14 West Product

Resolved

A fix has been implemented and Gross Orders and Revenue are now up to date in our data.

Some reports may not reflect the updates until their next refresh; however, Sales and Revenue reporting is now up to date in ThoughtSpot.
Posted Jun 24, 2025 - 12:12 EDT

Identified

We have identified an issue with Gross Orders and Revenue under reporting.

We are working on implementing a fix and will provide an update when available.

This is just a reporting issue.
Posted Jun 24, 2025 - 11:00 EDT
This incident affected: Data & Analytics.