A hotfix was deployed to address the validation issue between IRIS and the new version of Advantage.
The issue, which impacted the creation of promo codes—particularly for Lead Gen Efforts—now appears to be resolved. We are currently monitoring the system to ensure stability.
If you continue to experience issues, please reach out to the IRIS Team.
Thank you for your patience. — The IRIS Team
Posted Jun 23, 2025 - 10:51 EDT
Update
IRIS Campaign Code Issue – Partial Workaround Available
Workaround (Paid Efforts Only)
If you are creating a Paid Effort, and the IRIS Campaign you're using has a Campaign Code from Advantage, the promo code will generate as expected.
The issue only arises when creating a Paid Effort using an IRIS Campaign without an associated Advantage Campaign Code.
To work around this:
Create a Campaign Code in Advantage.
Add that Campaign Code to the IRIS Campaign.
Proceed to create the Effort/Promo Code as usual.
Lead Generation Efforts (No Workaround!)
There is currently no workaround for Lead Gen Efforts. At this time, Lead Generation links cannot be created in IRIS.
We’re actively investigating the issue and will provide further updates as soon as possible.
Thank you for your patience. — The IRIS Team
Posted Jun 23, 2025 - 07:44 EDT
Identified
ALERT…We have encountered a validation issue with the integration between IRIS and the new version of Advantage.
You may experience errors when trying to create promo codes in IRIS. (Specifically Lead Gen Efforts and potentially other niche examples). If you do encounter a error you can proceed with setting up the promo code directly in Advantage and then adding them to the IRIS effort to proceed.
The team will be addressing this issue as soon as possible. We will provide further updates as we work through the development necessary to correct this validation error.
If you have any issues with creating a promo code in Advantage please reach out to the Advantage team and they will be able to help.