ADVISORY - IRIS Issue – Editing Creatives/Offers

Incident Report for 14 West Product

Resolved

Hey everyone,
IRIS is now back working as expected—you can edit a Creative and Offer once more.
The issue was caused by a stopped service, which we have restarted.
Let’s call this one resolved. Thanks for your patience!
Posted Feb 19, 2025 - 09:39 EST

Investigating

Hey everyone,

We are currently experiencing an issue in IRIS. When attempting to edit a Creative or Offer, the page returns a 404 error.

Customer-facing pages remain unaffected.

Our team is actively investigating the issue, and we will provide an update within the next 90 minutes.

Thanks for your patience!
The IRIS team.
Posted Feb 19, 2025 - 09:30 EST
This incident affected: IRIS.