Power issues in 1001 Cathedral Street area
Incident Report for 14 West Product
Resolved
BGE has fully restored power in 1001 Cathedral St.
Posted Nov 20, 2024 - 11:08 EST
Update
The 1001 building continues to have power issues.
BGE has reported an ETA of 11:15am to have the problem fixed.
Does not appear that any systems are impacted.
Posted Nov 20, 2024 - 08:52 EST
Identified
BGE has reported power issues in the 1001 Cathedral Street area.
This is causing intermittent power issues through out 1001.
Again, not all power is out at the building.
BGE has given at ETA of 11:15am for getting power fully restored.

It is not clear at this time if any systems are impacted as it appears that only the 1001 building is affected.
Posted Nov 20, 2024 - 08:38 EST
This incident affected: IT (IT | General Operations).