ADVISORY - Outlook Delivery Delays

Incident Report for 14 West Product

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 09:19 EST

Investigating

Is the ability to take or process orders affected?
No

Are Customers able to access their products?
Yes

The Issue
Outlook/Office 365 is experiencing significant delays in sending/receiving email. Microsoft has identified the issue and is working to resolve.

Workaround
While emails are delayed, they will be eventually be sent/received so no emails should be lost.

Next Update
As available

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted Jan 22, 2026 - 14:58 EST
This incident affected: IT (IT | General Operations).