Potential Reporting Delays for Iterable Mailing Events

Incident Report for 14 West Product

Resolved

A fix has been issued and monitored since last week and we are now capturing all mailing events from Iterable for reporting on schedule, as expected.
Posted Oct 28, 2025 - 09:33 EDT

Identified

We are aware of potential reporting delays for Iterable mailing events in Thoughtspot and Qlik eComm reporting. During times when there are a high number of events, mailed events are sometimes missed in Datahub. There is a backfill job that runs prior to the 2PM Datahub refresh that grabs all of the missed events from the previous 24 hours and loads them. No events are lost. Based on the refresh, any campaigns that appear to be missing data, should be updated at 2PM the following day. Data Services is working on a long term fix.
Posted Sep 29, 2025 - 13:54 EDT
This incident affected: FinTech (Qlik Sense) and Data & Analytics, Thoughtspot.