CRITICAL - Impacts due to AWS Incident

Incident Report for 14 West Product

Resolved

Updates
The AWS incident has been resolved and all of our impacted systems have caught back up and are delivering data as per our existing SLAs. Please submit a ticket if you have any questions regarding the impact of this incident.

Thank you,

14West Technologies Support
Posted Oct 21, 2025 - 09:45 EDT

Identified

Is the ability to take or process orders affected?
No

Are Customers able to access their products?
Yes

The Issue
Due to the global AWS outage (https://health.aws.amazon.com/health/status) this morning we are seeing some impacts to our Agora systems. Current known impacts are reporting (Thoughtspot and Qlik) and any data delivered by the Data Services team (Marketing Profile to Blueshift & Iterable, IRIS Statistics).

The Impact
Data that is sourced from our Snowflake environment (hosted by AWS) is delayed.

For updates in real-time, you can check here at https://14west.statuspage.io/.

Thank you,

14West Technologies Support
Posted Oct 20, 2025 - 10:00 EDT
This incident affected: Data & Analytics.